Android Minimum Version 5.0 Requirement

With new, exciting features being added to the Invoice2go app, the minimum version required for Android users to have the ability to update our app’s software will now be Android versions 5.0 and higher.

If your device is on Android version 4.4 or below, you will no longer be able to access the Invoice2go app on your mobile device until you update your device’s software.

You will still be able to access your account on the web application.

The following steps will outline how you can update your Android to its latest version: 

Step 1: Make sure your device is connected to WiFi

Step 2: Tap on Settings

Step 3: Tap About 

Step 4: Tap System Software

Step 5: Tap Update Now

Your device will then update to the latest Android version. 

Please note, the steps to update your device's operating system will vary by your device type but should follow a similar flow. 

Have more questions? Submit a request